
An introduction to image analysis using ImageJ

Mark Willett, Imaging and Microscopy Centre,
Biological Sciences, University of  Southampton.

Pete Johnson, Biophotonics lab, 
Institute for Life Sciences University of  Southampton. 

1



2

“Raw Images, regardless of their aesthetics, are generally 
qualitative and therefore may have limited scientific use”. 

“We may need to apply quantitative methods to 
extrapolate meaningful information from images”.
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Examples of statistics that can be 
extracted from image sets

 Intensities (FRET, channel intensity ratios, target expression 
levels, phosphorylation etc).

 Object counts e.g. Number of cells or intracellular foci in an 
image.

 Branch counts and orientations in branching structures.

 Polarisations and directionality

 Colocalisation of markers between channels that may be 
suggestive of structure or multiple target interactions.

 Object Clustering

 Object Tracking in live imaging data.
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Regardless of the image analysis software package or 
code that you use….. 

• ImageJ, Fiji, Matlab, Volocity and IMARIS apps.

• Java and Python coding languages. 

….image analysis comprises of a workflow of predefined 
functions 
which can be native, user programmed, downloaded as plugins or 
even used between apps. 

This is much like a flow diagram or computer code.
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Here’s one example of an image analysis workflow:

Acquisition Processing

Make binary 
mask

Thresholding

Make ROI from 
binary using 

“Create selection”

Apply ROI 
to original 

image

Choose 
measurement 

type(s)

Make 
measurements

Repeat n
times

Calculate x̄, 
SD, TTEST 

and Δ

Chart data 
and interpret

Save to ROI 
manager
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A few example Functions that can inserted into an image analysis workflow. 
You can mix and match them to achieve the analysis that you want.
**If there is an ROI present on the image, Fiji will only execute the function on the part of the 
image inside the ROI**

• Automatic object detection 

• Binarisation

• Image intensity Thresholding

• Mask generation

• Automatic generation of ROIs

• Skeletonization

• Vectorisation

• Object tracking

• Various colocalisation algorithms

• “Image math”
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Particle selection

If you had multiple objects (cells, particles, nuclei etc) you could count them 
manually, but you can use imageJ/Fiji to do it for you and create masks and 
ROIs for measurement too.

This function enables the automatic detection of multiple objects in the 
image.  

However, it needs the application of some other functions first.  We need a 
binary (black and white only) image to help the particle analysis function 
detect the objects.

To tell Fiji which pixel grey values to make white and which ones black on the 
binary image, we need to threshold the image.  Values above and below the 
selected threshold will be sent to either black or white.

Acquisition Make binary 
imageThresholding

Automatically 
detect objects 

on binary image

Watershed
(if needed)



Particle selection

Open image “Nuclei”.
Select Image>Adjust>Threshold.

Tick “Dark background” and select “Default” and Red” from the pulldown menus.  Using 
the top slider, threshold image until the nuclei are red against a dark background, then 
click “Apply” and then Process>binary>make binary to convert to a binary image.
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Particle selection

Select Process>Binary>Watershed.

This function attempts to separate objects based on their circularity.
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Particle selection

(3) Set the particle size and circularity discrimination and do the analysis

Select Analyse>Analyse Particles.  

Adjust Size to 200-1500 and Circularity discrimination to 0.40 - 1.00 and select “Show: 
Outlines”. *Particles that are larger or less circular will be excluded*

Tick “Summarize” and “Exclude on edges” and click ”OK”, 
A results box should appear with a particle count 
and other information.

1

2

3

1 2

3
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Keep the binary of the nuclei – you 
need it for the next bit!
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Particle analysis – Area and Intensity

Now you know how to select particles, lets use the workflow to do an actual 
analysis.

This time we will use the binary image to make a separate ROI for each 
nucleus and then measure the area and mean intensity of each one.

Then we’ll calculate mean  and SD for both measurements for the whole 
population.

Acquisition

Make binary 
image

Thresholding

Automatically 
detect objects

on binary image

Watershed
(if needed)

Make ROIs for 
each object

Choose 
measurement 

type(s)

Apply ROIs to 
original image

Make 
measurements

Calculate 
mean 

intensity, 
area and SD



Particle analysis – Area and Intensity

Select the watershed binary image and select Analyze>Measure>Analyse Particles again
Repeat the particle analysis step tick “Add to manager”. Click “OK”.

The ROI manager should pop up with a list of separate ROIs (one for each nucleus), which 
will also be displayed as an overlay on the watershed binary image.

Select Analyze>Set Measurements. And select which measurements you want to make, 
for example tick “Area” and “Mean gray value”.2

1

1

4

2
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Particle analysis – Area and Intensity

Open the original unthresholded image “Nuclei” again. Individual nuclei can be selected 
and measured using the ROI manager (you can click the top one and  scroll through with 
the mouse wheel).  Select “Measure” or “Ctrl + M” to make individual measurements.

Make multiple selections by holding down [Ctrl] and Left-clicking.

Scroll to the first ROI in the ROI manager. Hold down [shift] and Left click. Scroll to the 
last ROI. Hold down [shift] and Left click again to select all of the ROIs.

Select “Measure”.

tick “Show all” to display all of the 
particles in the analysis
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Mean grey value of particle
Area of particle 

Particle number
If image is not calibrated, measurement results will be 
displayed in pixel units.

Particle analysis – Area and Intensity

In the results window, select Results>Summarize to get mean and standard deviation 
data.
Data can be copied and pasted into Excel for further analysis.
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Segmentation

We can use segmentation to separate a single image into separate 
components based on shape, size or intensity to make image analysis of each 
of those components possible.

For this we use “masks”. Masks are just a binary image being used for “Image 
calculation” (e.g. digital subtraction) to extract or remove specific structures. 
In this example we’ll use a particle analysis to make the masks and remove the  
chloroplasts from an image of a plant section.

Acquisition

Make binary 
image

Thresholding

Use particle detection 
with size and shape 

discrimination to select 
chloroplasts

Watershed
(if needed)

Make a mask of 
the chloroplasts

Subtract mask 
of chloroplasts 
from original 

binary



Segmentation
(1) Make a binary image to allow the software to identify the particles.

Open image “Brightfield” We just want to analyse chloroplasts (the small circular foci).
Untick “Dark background”, Select “Red” in the pull down menu

Image>Adjust>Threshold. Threshold using the “Minimum“ (top) slider to find the range 
of image intensities that excludes the cell walls while preserving other structures (I chose 
12495), they should turn red. and click “Apply”. Then “Process>Binary>Make binary”
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Segmentation

Analyze>Analyze Particles. Select “Show: Masks” and “Exclude on edges”  Adjust the size 
(30-200) and circularity (0.6-1.00) discrimination of the particle analysis to select only the 
chloroplasts. Click “OK”. A binary image of the chloroplasts appears.
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Segmentation

Select Process>Image Calculator. Select your original thresholded binary image as 
“image 1” and the binary mask of the chloroplasts as “image 2”.

Select “Subtract”. A new image with the chloroplasts subtracted appears.
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Binary of chloroplasts
 Particle analysis 
 Overlay image
 Make into ROIs for 

further analysis
 Further segmentation

Binary with chloroplasts 
removed
 Overlay image
 Analyse stuff that 

isn’t chloroplasts
 Further segmentation

Segmentation

Images can now be used for analysis (e.g. particle count and area, create ROIs to analyse 
the original unthresholded images, as an image overlay or further segmentation).

Original binary
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(I used Edit>Invert for clarity)
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Segmentation

Question: 

How could you create a grey scale image (rather than a binary) of the plant 
section without chloroplasts?
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Acquisition

Make binary 
image of 
branched 
structure

Thresholding
Convert binary to a 
vectorised image 

(Skeletonize)

Fill gaps in 
the branched 

structure
(if needed)

Do analysis

Analysing branched structures

We can analyse branched structures using “skeletonisation” of binary images

Branched structures could be neurons, blood vessels, lymph nodes or glands, 
root structures on plants or any other filamentous branching structure.

From these we might want to extract information as to the number or length 
of branches present, the number of branches per branch point, or the 
tortuosity of the structure (how “gnarly” it is). 



Open image: Neuron (green).tif

Threshold the image 
Image>Adjust>Threshold. Choose “Default” and “Red” in the pulldown menus.
Tick “Dark Background”
To threshold the image, move the top slider until all of the foreground is red. Try to 
preserve the continuity of the axons as much as possible.  When done click “Apply”.

Branch analysis
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Skeletonise the binary image
Process>Binary>Skeletonize. 

This converts the binary image to vectors – discrete lines with a known start and 
finish position. 
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Analyse the vectorised image
Analyse>Skeleton>Analyze Skeleton 2D/3D. 
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Tick:

Show detailed info and Display labelled skeletons

Select OK
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On the resulting image, branches are labelled in orange, junctions in magenta and 
end points in blue. 

(Zoomed in with [Ctrl] + mouse wheel) 
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There are two results windows. One gives you general information about each 
complete skeleton in the image. E.g. how branched it is and how many double or 
triple junctions there are.

The other gives information about each branch in the skeleton. E.g. Branch length vs
Euclidian distance will give you information about tortuosity. You could bin number of 
branches of each type depending on the branch length etc.
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Colocalisation analysis.

Colocalisation is a process where we attempt to quantify the relationship between 
markers from two different channels.

There are many methods, but they fall into two main categories – quantifying pixel 
overlap or quantifying co-dependency using regression.  For this workshop we’ll focus 
on the regression method, however here are some other workflows.

Simple Pearson’s R analysis (Regression, background insensitive)

Acquisition
(2 channels)

Compare ROI 
in Channel A 
to Channel B 
using Linear 
regression

Analyse output. 
Significant if 

R > 0.5 or R < -0.5
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Acquisition
(2 channels)

Analyse output. 
Significant if

R(obs) ≠ R(rand)

Compare ROI in
Channel A to 

Channel B using 
Linear regression 

= R(obs)

Randomly scramble 
Channel A at the 
scale of the PSF
(calculated from 

N.A. and λ)

Compare ROI in 
scrambled channel 
to Channel B using 
Linear regression 

= R(rand)

Costes’ method (Regression, background insensitive)
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Acquisition
(2 channels)

Quantify proportion of 
pixels in channel A 

overlapping channel B
= M1

Threshold
Each 

channel

Make binary of each 
channel

Or ensure 
background has grey 

value of zero

Manders Coefficients (Overlap, background Sensitive)

We may know that two targets colocalise from their Pearson’s R, but we can also 
quantify how much of each target is colocalising with the other channel.

Quantify proportion of 
pixels in channel B 

overlapping channel A
= M2
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Acquisition
(2 channels)

Use channels as a mask 
to subtract non-

colocalising pixels 

Threshold
Each 

channel

Make binary of each 
channel

Or ensure 
background has grey 

value of zero

Digital subtraction (Overlap, background Sensitive, not quantitative)

Produce new image of 
overlapping pixels only



Pearson’s colocalisation analysis

Colocalisation analysis provides a statistically testable numerical value relative to the 
degree of colocalisation between two image channels. 

Pearson’s colocalisation coefficient uses linear regression to measure the co-dependency 
of the variations in grey intensity across two channel images and returns the value “R”.

The value for R can range from -1 to +1  and can be interpreted as follows:

R =  -1  The two stains are absolutely mutually exclusive

R =   0   No significant co-dependency between the two stains – random distribution

R =   1   The two stains are absolutely dependent (A value very close to 1 may indicate
experimental error or channel cross-talk)
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Pearson’s colocalisation analysis

As R-values may be positive but still close to zero, a value closer to 0.5 (or above) is 
considered statistically significant. However, the significance of Pearson’s R can be further 
tested using Costes’ approximation:

• The channel images are analysed to return the observed Pearson’s coefficient R(obs).

• One of the channel images is then randomised using a unit size determined by the 
optical resolution of the image determined by a PSF calculated from the N.A. of the 
objective lens used.

• The randomised image is then compared to the intact channel image using Pearson’s 
colocalisation coefficient.

• This process is repeated 200 times to return R(rand) with an expected outcome close to 
zero, and a standard deviation is calculated.
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Pearson’s colocalisation analysis – worked example

Open channel images “Epsin 1.tif” and ““AP1.tif” 
Select Plugins>Colocalisation Analysis>Colocalisation Test.
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Pearson’s colocalisation analysis – worked example

Select Epsin 1 as Channel 1 and AP1 as Channel 2 and click “OK”

Enter the channel 2 wavelength and the objective N.A. Iterations should be set to 200.

Click “OK”.

2
1

2

1
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Pearson’s colocalisation analysis – worked example

A results window pops up summarising the R(obs) and R(rand) for the two channels.
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t=0 +5 min +10 min +15 min

The microscope is focussed the specimen (e.g. paricles being transported on an axon) and a 
sequence of images is collected at multiple time-points

Images are converted to binary (black and white) and combined into a single “t-stack” file 
(a scrollable time-lapse movie).

Manual tracking



38

Acquisition 
of t-stack of 

images

Threshold 
stack

(optional)

Manually 
select 

particle to 
record x,y

pixel 
values

Repeat for n
particles

Auto-
Increment 

stack to next 
frame for n 

frames

Calculate velocity, 
vector, total 
distance and 

Euclidian distance 
that each particle 

has moved

Manual tracking

Can be used to track intracellular particles/organelles or individuals within larger 
motile populations, e.g. cells.
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Measuring axonal transport

Calibrate the images:

Open image stack “TeNTHc_kd”.

Select Analyze>Set Scale...

Enter the microns/pixel and “um” as the unit of length and click “OK”
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Measuring axonal transport

Open the manual tracking plugin:

Plugins>Tracking>Manual Tracking : http://rsbweb.nih.gov/ij/plugins/track/track.html

Enter the calibration parameters:
“Time interval” (seconds) and 
“x/y calibration” (microns/pixel)

http://rsbweb.nih.gov/ij/plugins/track/track.html
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1

2

3

To start the analysis of each particle, click “Add 
track”

Using the mouse cursor, click on the particle 
that you want to track. The stack will increment 
by one frame. Continue clicking on the particle 
until you reach the end of its travel.

When you have finished tracking the particle, 
click “End track”. Click “Add track” to start 
tracking a new one.

Measuring axonal transport
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As you end each track, data showing the 
distance travelled per frame and velocity are 
added to the results window.  This data can be 
copied and pasted into excel for further 
analysis 

You can review the particles that you have 
tracked by clicking on the “Overlay Dots” 
function.

Measuring axonal transport
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Macros

Macros are a series of code steps used to process images in a quick and repeatable way

ImageJ macros are based on java but you don’t need to know java to create one

The macro recorder tool allows you to easily turn image analysis steps into a script
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Macros

To create a new macro go to Plugins > New > Macro

You can copy and paste step from the recorder into the macro

They can be saved as macro files or as text documents

An example macro

This macro takes a folder of images, crops them, scales them, adds a scale bar and saves 
them into a new folder with meaningful names. 
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This is a variable

Variables can be numbers, strings, arrays etc their value can change which is useful

ImageJ has hundreds of predefined macro functions that streamline the process of image 
analysis, you can find a list Googling “ImageJ macro functions”

For Loops, allow you to repeat the same set of commands for multiple images without needing 
outside input

Comments are bits of code that the computer doesn’t read and are marked with a “//”, 
commenting macros is useful to remind yourself what each step is doing

This predefined macro function

This is a “for loop”

This is a comment
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Macros
An example macro for analysis of images
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